Failure to upload large files (1.74Gb) on ic network

I am trying to upload 1.74Gb file over to asset canister, but without luck - yesterday it was 504 error, today it is http2 error with weird ending: “protocol error: not a result of an error”

➜  thirst git:(main) ✗ dfx deploy --network=ic
Deploying all canisters.
All canisters have already been created.
Building canisters...
Installing canisters...
Upgrading code for canister www, with canister_id vwk6n-XXXX-cai
Module hash e0df779f65fe44893d8991bef0f9af442bff019b79ec756eface2b58beec236f is already installed.
Authorizing our identity (registered_owner) to the asset canister...
Uploading assets to asset canister...
Starting batch.
Staging contents of new and changed assets:
  /index.html 1/1 (3390 bytes)
  /index.html (gzip) 1/1 (1457 bytes)
  /_img/beach.png 1/1 (159151 bytes)
  /_img/ 1/909 (1900000 bytes)
  /_img/ 273/909 (1900000 bytes)
An error happened during communication with the replica: error sending request for url ( http2 error: protocol error: not a result of an error

With local deployment had a little better luck, but still, it gets stuck on and time outs:

  /_img/ 807/909 (1900000 bytes)
  /_img/ 808/909 (1900000 bytes)

The request timed out.

I have went through Topic about http2 here in forum and tried suggestions there, however no luck so far. Tried also redeploy multiple times and see that cycles are burned, but deploy never finished.

1 Like