Does the Ledger FIDO app still work to login II?

I had the Ledger FIDO configured as a recovery method, and also used it to login to my II. I tried today and seems it does not work anymore, and was wondering if it is an issue I face, or something else.

thank you

1 Like

Hi @radudaniel

Yes, this should still work. I just checked with my Ledger and it worked fine.


I was able to login today too.

1 Like

this is the message I get when trying to authenticate using the FIDO on the Nano Ledger. I removed it, added it again to see if it works. It works to add it. But when I want to log in, I get the message in the screenshot above.

Tried 4 different browsers on my macbook, I get the same result.

Have you checked the url @radudaniel ?

Maybe you are sometimes on :

and not on :

Or the contrary. Be careful about keeping the same ones.

1 Like

I only access

The “funny” thing is I can add my FIDO Ledger as a recovery device, but then when I try to login I get the message in the image above.

But login and recover are different things. You can’t login with you recovery device. You can just use it to recover. So if you try to login with a FIDO set for recovery, it is normal.

Are you saying that when you try to recover, it does not work ? Or that when you try to login, it does not work. In the second case. Normal.


Oh LoL oh my :slightly_smiling_face: Now it works, seems for some reason I remembered also using it for login not just recovery. Well thank you, it works as it was supposed in the first place.