Dfx nns install failed on dfx version 0.19.0

I just upgraded my dfx from 0.15.2-beta to 0.19.0 (motoko: v0.11.0) and the dfx nns install threw the following:

I switched the dfx version to 0.18.0 and dfx nns install is now working

1 Like

It looks to me as if the really interesting bit - why the xdr rate is not set - is probably higher up. But as long as this is reproducible it should be fixable. :smiley: It looks as if maybe @Andre-Popovitch could help? (judging by commits here)

Hi, could you share the exact commands that cause you to run into this output? I wasn’t able to reproduce the issue myself:

❯ dfx --version
dfx 0.19.0

❯ dfx extension install nns --version 0.4.0                          
  Version v0.19.0 installed successfully.
  Extension 'nns' installed successfully

❯ dfx nns --help
Toolkit for interacting with the Network Nervous System.

Usage: dfx nns [OPTIONS] [COMMAND]

  import   Import NNS API definitions and canister IDs.
  install  Install an NNS on the local dfx server.
  help     Print this message or the help of the given subcommand(s)

  -v, --verbose...                                                     Displays detailed information about operations. -vv will generate a very large number of messages and can affect performance
  -q, --quiet...                                                       Suppresses informational messages. -qq limits to errors only; -qqqq disables them all
      --log <LOGMODE>                                                  The logging mode to use. You can log to stderr, a file, or both [default: stderr] [possible values: stderr, tee, file]
      --logfile <LOGFILE>                                              The file to log to, if logging to a file (see --logmode)
      --identity <IDENTITY>                                            The user identity to run this command as. It contains your principal as well as some things DFX associates with it like the wallet [env: DFX_IDENTITY=]
      --provisional-create-canister-effective-canister-id <PRINCIPAL>  The effective canister id for provisional canister creation must be a canister id in the canister ranges of the subnet on which new canisters should be created
  -h, --help                                                           Print help
1 Like

I just realized that you were talking about dfx nns install, not installing dfx nns :smiley: However I am still not able to reproduce the issue (dfx nns install · GitHub)

Sorry for the late reply.
Here is the full log. Previously I stop the command prematurely due to seeing it Panicked at... such as screenshot below.

But now I just let it run and it says NNS CANISTER INSTALLATION COMPLETE.

Perhaps I’m wrong. If so, sorry for the false alarm.

Nice, glad it seems to have worked the second time :smiley: