connect2ic/react Bug

When I use connect2ic, the wallet is normally linked to the website, but when I call approve, it tells me Error: Fail to verify certificate
image

1 Like

Will often appear randomly this problem, when I constantly refresh the website or disconnect the wallet will suddenly become better!!

Or what are your similar libraries using

Since connect2ic hasn’t received updates for a year, it might not be the best choice for development. If you’re in need of Internet Identity (II), I suggest considering the @ic-reactor library, which I am currently developing. Feel free to share your entire component, and I’ll assist you in integrating it with @ic-reactor. You might be impressed with the results!

1 Like

Within the WG Identity & Authentication we’ve been working on standardizing the dapp ↔ wallet communication.

Some wallets have started implementing these standards and their extensions. And a client library can be found here. Most of this is all work in progress, hopefully in the coming months this is all more finalized and generally available.

2 Likes

Thank you for your reply. I am participating in ICP Grant, and I am limited in time because of this problem. I will switch to your development kit after submitting it for review this time! :grinning:

Thank you for your reply, I don’t know if other people have this kind of problem ~ but I personally find this question very strange! All kinds of phenomena show that my wallet is successfully linked to the website, but it prompts me Error: Fail to verify certificate, and it appears randomly. The solution is always to disconnect the wallet and refresh the website! But this happens with canister, which is a very basic and very frequent use. :disappointed_relieved:

hello @_Eric

Can you share your Client configuration?
I’ve encountered the same problem in the past.

Here is the working configuration that I’m using now:

const client : Client = createClient({
providers: [
new PlugWallet(),
],
globalProviderConfig: {
dev: false,
host: “https://icp0.io”,
autoConnect: false,
},
})

connect2ic version: 0.2.0-beta.24

hello @chrab
image

image

Here’s my configuration

did you try with the connect2ic version 0.2.0-beta.24?

Does this have UI elements?

No it does not, For now it’s just support Internet Identity as login option.