Cannot download CMC canister wasm anymore

I’ve got a script in Juno (source) that downloads and installs the CMC canister locally.

While trying to install a clean project from scratch, I discovered my script does not work anymore because the source of the CMC wasm is not accessible anymore.

Anyone knows where was the wasm file was moved?

This fails:

curl -o cmc.wasm.gz "$IC_VERSION/canisters/cycles-minting-canister.wasm.gz"
gunzip cmc.wasm.gz

Because returns

  <Message>Access Denied</Message>
1 Like

Forgot to close this. I believe wasm hosted by are deleted after 6 months, therefore the “old” wasm I was trying to download was not available anymore.

To solve the issue I bumped the commit number to most recent and luckily, there was no breaking changes. So my deploy script for local development was still ok.

I would like to add that in this form, the CMC will not be able to create canisters using the notify_create_canister method. I ran into this issue here and the solution suggested was to deploy a locally modified version of CMC. I wrote a small readme how to build a custom CMC, a link to I hope this helps someone :slightly_smiling_face:

1 Like

Thanks for the readme and…starred :star:

1 Like

In case someone is facing yet another issue trying to deploy the Cmc locally

Error: Failed while trying to deploy canisters.
Caused by: Failed while trying to deploy canisters.
Failed while trying to install all canisters.
Failed to install wasm module to canister ‘cmc’.
Failed during wasm installation call: The replica returned a replica error: Replica Error: reject code CanisterError, reject message Canister rkp4c-7iaaa-aaaaa-aaaca-cai trapped explicitly: Panicked at ‘Deserialization Failed: “Fail to decode argument 0 from table0 to opt record {\n exchange_rate_canister : opt variant { Set : principal; Unset };\n last_purged_notification : opt nat64;\n governance_canister_id : opt principal;\n minting_account_id : opt text;\n ledger_canister_id : opt principal;\n}”’, rs/rust_canisters/dfn_core/src/, error code None

Try again. For no reason, I just restarted my script and it worked out.

1 Like