ICDevs.org Bounty 1 - Basic Tutorial and Site

Hey @skilesare, I created the PR with those first 2 tutorials and started working on the next. Please let me know in case you would like to change something.

@skilesare I’ve got another two. PR created :slight_smile: there seems to be a conflict with existing files, if it is a problem let me know and I will make another one only with new ones.

Next on on types

Serving SVG over HTTP

Will be happy for a feedback, otherwise Im gonna do the next one.

What files are causing a problem? Can you push a branch and I can investigate?

@skilesare sure it is pushed here GitHub - lukasvozda/ic_devs_org_tutorials at new-tuts

And here is the PR Added Understanding Types and SVG over HTTP tutrial by lukasvozda · Pull Request #2 · icdevs/ic_devs_org_tutorials · GitHub

I can see tutorials.icdevs.org is broken after the merge @ferMartz and new tutorials are not there. Do you want me to change something? Weird that it went well through my forked repo and fleek site as well.

It looks like retype upgrade to 2.22 or something? There are merge conflicts through the entire codebase. I’ll revert back to where we were before pull 2 and we’ll need to do some merge clean up.

The site works locally just fine. I also fixed the conflicts as I did in my previous merge.

I’m not sure exactly what is happening but it looks like retype changed the way you publish the site.

I do not remember how Austin configured the site and I don’t have access to the settings.

Here is the link Austin:

https://retype.com/hosting/github-pages/#step-2-configure-github-pages

I removed the merge conflicts, but apparently, the new version messed some stuff up. @ferMartz, can you pull and test? I guess there were some breaking changes in the version move and we need to give it some tlc.

@skilesare I did pull and test locally yesterday. I will check the documentation again and see if I missed anything.

I got it working…looks like the issue was that I had to build locally and then push to main.

@skilesare awesome…I was banging my head on the wall yesterday because everything was working as expected locally. :grimacing:

Hey @skilesare I’ve got the 5th one, link to my Fleek page:

PR here, again there are similar conflicts as before :frowning:

I also fixed a lot of typos and added contact to the footer of tutorials. Please let me know in case of anything.