# Frequent ingress\_expiry error on update calls

**URL:** <https://forum.dfinity.org/t/frequent-ingress-expiry-error-on-update-calls/35517>\
**Category:** Developers\
**Tags:** Discussing\
**Created:** [September 25, 2024, 1:32pm UTC](https://forum.dfinity.org/t/frequent-ingress-expiry-error-on-update-calls/35517 "2024-09-25T13:32:16Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![h1teshtr1path1](https://sea1.discourse-cdn.com/flex023/user_avatar/forum.dfinity.org/h1teshtr1path1/32/24662_2.png) [@h1teshtr1path1](https://forum.dfinity.org/u/h1teshtr1path1)\
**Post date:** [September 25, 2024, 1:32pm UTC](https://forum.dfinity.org/t/frequent-ingress-expiry-error-on-update-calls/35517/1 "2024-09-25T13:32:16Z")

</div>

I am getting these errors on update calls on canisters frequently. How to tackle this?  
Subnet Id : [e66qm-3cydn-nkf4i-ml4rb-4ro6o-srm5s-x5hwq-hnprz-3meqp-s7vks-5qe](https://dashboard.internetcomputer.org/subnet/e66qm-3cydn-nkf4i-ml4rb-4ro6o-srm5s-x5hwq-hnprz-3meqp-s7vks-5qe)

I would love to know the exact reason behind this and what steps are being taken to tackle this? As with increased activities in the ecosystem, these errors have become very frequent.

---

<div class="post-metadata">

**Author:** ![jamesbeadle](https://sea1.discourse-cdn.com/flex023/user_avatar/forum.dfinity.org/jamesbeadle/32/10110_2.png) [@jamesbeadle](https://forum.dfinity.org/u/jamesbeadle)\
**Post date:** [September 25, 2024, 1:48pm UTC](https://forum.dfinity.org/t/frequent-ingress-expiry-error-on-update-calls/35517/2 "2024-09-25T13:48:25Z")

</div>

Yes I am getting this too.

---

<div class="post-metadata">

**Author:** ![Vivienne](https://sea1.discourse-cdn.com/flex023/user_avatar/forum.dfinity.org/vivienne/32/29170_2.png) [@Vivienne](https://forum.dfinity.org/u/Vivienne)\
**Post date:** [September 26, 2024, 6:25am UTC](https://forum.dfinity.org/t/frequent-ingress-expiry-error-on-update-calls/35517/3 "2024-09-26T06:25:48Z")

</div>

> [@Agent-JS 2.1.0 is Released!](https://forum.dfinity.org/t/agent-js-2-1-0-is-released/35090/11):
>
> Hello Jake The root of the first error you encountered is the fact that a client’s time can be ahead the replica’s time which receives the message. Moreover the time certified by the subnet’s nodes can differ from both those times as well. We are aware of the problem and we’re discussing different options to improve the situation. We should be able to communicate a more concrete plan soon. For the second problem, please note that the ingress expiry ensures that a subnet will not start executin…

---

<div class="post-metadata">

**Author:** ![peterparker](https://avatars.discourse-cdn.com/v4/letter/p/b9bd4f/32.png) [@peterparker](https://forum.dfinity.org/u/peterparker)\
**Post date:** [September 27, 2024, 1:51pm UTC](https://forum.dfinity.org/t/frequent-ingress-expiry-error-on-update-calls/35517/4 "2024-09-27T13:51:17Z")

</div>

Follow-up:

> [@Ingress Expiry Issue - Your Input Needed!](https://forum.dfinity.org/t/ingress-expiry-issue-your-input-needed/35609):
>
> Hi everyone wave, Over the past few weeks, there have been several reports on the forum from devs encountering ingress expiry issues, such as the following: Error: ReplicaTimeError: Specified ingress\_expiry not within expected range: Minimum allowed expiry: 2024-09-25 13:57:00.580809774 UTC, Maximum allowed expiry: 2024-09-25 14:02:30.580809774 UTC, Provided expiry: 2024-09-25 13:57:00 UTC While we provided some valid explanations and future improvements in various threads yesterday (for …
