# Dfx 0.12.0 install fail after upgrade

**URL:** <https://forum.dfinity.org/t/dfx-0-12-0-install-fail-after-upgrade/16461>\
**Category:** Developers\
**Tags:** Functional-Programming\
**Created:** [November 9, 2022, 1:31pm UTC](https://forum.dfinity.org/t/dfx-0-12-0-install-fail-after-upgrade/16461 "2022-11-09T13:31:55Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Gabriel](https://sea1.discourse-cdn.com/flex023/user_avatar/forum.dfinity.org/gabriel/32/546_2.png) [@Gabriel](https://forum.dfinity.org/u/Gabriel)\
**Post date:** [November 9, 2022, 1:31pm UTC](https://forum.dfinity.org/t/dfx-0-12-0-install-fail-after-upgrade/16461/1 "2022-11-09T13:31:55Z")

</div>

I upgraded this morning to 0.12.0 and even with everything fresh/removed on install I get:

> dfx start --clean --verbose  
> Running dfx start for version 0.12.0  
> There is no project-specific network ‘local’ defined in /home/gabriel/projects/dragginz/dfx.json  
> Using the default definition for the ‘local’ shared network because /home/gabriel/.config/dfx/networks.json does not exist.  
> Local server configuration:  
> bind address: 127.0.0.1:4943  
> bitcoin: disabled  
> canister http: enabled  
> log level: Error  
> replica:  
> subnet type: Application  
> log level: Error  
> data directory: /home/gabriel/.local/share/dfx/network/local  
> scope: shared  
> Starting canister http adapter…  
> canister http adapter ready  
> Starting replica…  
> replica ready on 36449, so re/starting icx-proxy  
> Starting icx-proxy…  
> version: 0.8.1  
> Nov 09 12:35:54.657 INFO Log Level: INFO  
> Nov 09 12:35:54.657 INFO Starting server. Listening on [http://127.0.0.1:4943/](http://127.0.0.1:4943/)  
> Dashboard: [http://localhost:36449/\_/dashboard](http://localhost:36449/_/dashboard)  
> Nov 09 13:13:11.380 WARN Internal Error during request:  
> hyper::Error(  
> BodyWrite,  
> Os {  
> code: 32,  
> kind: BrokenPipe,  
> message: “Broken pipe”,  
> },  
> )

> Installing code for canister global, with canister ID rkp4c-7iaaa-aaaaa-aaaca-cai  
> Installing code for canister main, with canister ID rno2w-sqaaa-aaaaa-aaacq-cai  
> Error: Failed to install wasm module to canister ‘main’.  
> Caused by: Failed to install wasm module to canister ‘main’.  
> Failed to install wasm in canister ‘rno2w-sqaaa-aaaaa-aaacq-cai’.  
> Failed to install wasm.  
> The replica returned an HTTP Error: Http Error: status 500 Internal Server Error, content type “”, content: Internal Server Error

Not sure what the issue is. Same code worked on 0.12.0-beta3

Any help is appreciated it.

---

<div class="post-metadata">

**Author:** ![ericswanson](https://sea1.discourse-cdn.com/flex023/user_avatar/forum.dfinity.org/ericswanson/32/622_2.png) [@ericswanson](https://forum.dfinity.org/u/ericswanson)\
**Post date:** [November 9, 2022, 7:17pm UTC](https://forum.dfinity.org/t/dfx-0-12-0-install-fail-after-upgrade/16461/3 "2022-11-09T19:17:06Z")

</div>

What’s the size of the .wasm file?

`ls -l .dfx/local/canisters/*/*.wasm`

---

<div class="post-metadata">

**Author:** ![Gabriel](https://sea1.discourse-cdn.com/flex023/user_avatar/forum.dfinity.org/gabriel/32/546_2.png) [@Gabriel](https://forum.dfinity.org/u/Gabriel)\
**Post date:** [November 9, 2022, 8:58pm UTC](https://forum.dfinity.org/t/dfx-0-12-0-install-fail-after-upgrade/16461/4 "2022-11-09T20:58:08Z")

</div>

-rw-r–r-- 1 gabriel gabriel 387726 Nov 9 15:12 .dfx/local/canisters/cdn/cdn.wasm  
-rw-r–r-- 1 gabriel gabriel 1168802 Nov 9 15:12 .dfx/local/canisters/content/content.wasm  
-rw-rw-rw- 1 gabriel gabriel 324196 Nov 9 15:12 .dfx/local/canisters/frontend/frontend.wasm  
-rw-r–r-- 1 gabriel gabriel 800002 Nov 9 15:12 .dfx/local/canisters/global/global.wasm  
-rw-r–r-- 1 gabriel gabriel 5990050 Nov 9 15:11 .dfx/local/canisters/main/main.wasm  
-rw-r–r-- 1 gabriel gabriel 898165 Nov 9 15:10 .dfx/local/canisters/player/player.wasm
